Tampilkan posting dengan label Network. Tampilkan semua posting

Selasa, 14 Januari 2014

Cara Konfigurasi VLAN pada Cisco Packet Tracer

  6 komentar
1/14/2014 02:16:00 PM

Cara Konfigurasi VLAN pada Cisco Packet Tracer - Salam sobat blogger, kali ini Santekno akan menjelaskan konfigurasi VLAN (Virtual LAN). VLAN adalah aplikasi yang digunakan pada jaringan komputer khususnya layer 2 dan perangkat yang digunakan adalah Switch. Santekno telah menjelaskan pada postingan sebelumnya yaitu Pengertian VLAN (Virtual LAN) dengan detail dan jelas.
Konfiguras VLAN
Dan sekarang Santekno akan menjelaskan penerapanya pada Packet Tracer VLAN tersebut. Sesuai dengan topologi yang sudah dibuat dengan sederhana, konfigurasi VLAN ini disertai dengan tutorial yang lengkap diantaranya file Packet Tracer, file Konfigurasi serta Video tutorial yang sudah Santekno Upload di Youtube.

Sekilas mengenai VLAN adalah suatu aplikasi pembagi network yang bisa digunakan di Switch Layer 2. Biasanya Switch Layer 2 tidak mendukung aplikasi pembagi network karena pengenalan Network itu terjadi pada Layer 3 yang digunakan pada perangkat Router. VLAN cara terbaik untuk pembagian Network yang sederhana di dalam gedung yang berlantai ataupun tidak karena ini menangani masalah Local Area Network.


Bagi sobat yang sudah berikut ini adalah video tutorial cara konfigurasi VLAN pada Cisco Packet Tracer yang lebih rinci dan complete disertai dengan penggunaan router sebagai Penghubung antar network. Dan juga Santekno memberikan konfigurasi DHCP server di Router agar client tidak perlu memasukkan IP secara statik.



Lebih lengkap lagi jika sobat mengunduh konfigurasi ini dengan beberapa file yang Santekno sudah sediakan tinggal kopi dan konfigurasikan dengan baik dalam packet tracer. Berikut ini file untuk latihan bagi sobat yang ingin mempelajari lebih lanjut lagi.


DOWNLOAD KONFIGURASI VLAN DOWNLOAD VLAN PACKET TRACER

Sekian penjelasan Cara Konfigurasi VLAN pada Cisco Packet Tracer. Semoga bermanfaat bagi sobat semua, jangan lupa komentar juga di blog Santekno ya ^_^

Read More

Rabu, 27 November 2013

Jenis-jenis Serangan pada Jaringan Komputer

  3 komentar
11/27/2013 10:22:00 AM

Jenis-jenis Serangan pada Jaringan Komputer - Salam sobat blogger, Santekno akan menjelaskan berbagai macam dan jenis serangan yang ada pada jaringan komputer. Banyak sekali serangan yang dilakukan seorang hacker agar bisa menjebol suatu pertahanan dalam suatu jaringan LAN, MAN atau bahkan WAN.

Serangan jaringan Komputer ini memang sangat membahayakan bagi keamanan dan jaringan yang sudah kita buat, contohnya untuk sebuah perusahaan mempunyai data yang sangat rahasia dan tidak boleh data tersebut disebarluaskan di jaringan internet. Maka perlu pengamanan yang sangat ketat dari berbagai tahapan layer dalam jaringan komputer. 

Serangan Jaringan komputer (hacking)


Kita tahu bahwa berdasarkan OSI layer jaringan komputer terbagi menjadi 7 bagian diantaranya sebagai berikut Aplication, Presentation, Session, Transport, Network, Data Link, Physical. Di semua layer seharunya kita bisa mengamankan jaringan komputer tersebut, oleh karena itu Santekno akan menjelaskan beberapa serangan pada jaringan komputer berdasarkan OSI layer.

Berikut adalah susunan model OSI dari layer paling atas (layer 7) sampai layer paling bawah (layer 1) beserta fungsi yang dijalankan :
Application Menyediakan dukungan untuk aplikasi seperti FTP, Telnet, dan HTTP
Presentation Enkripsi, SMB, ASCII, format data
Session Flow control data, inisiasi dan terminasi koneksi
Transport Komunikasi end-to-end (aplikasi ke aplikasi), layanan TCP dan UDP.
Network Routing (OSPF, dan lain-lain). IP addressing
Data Link Lan card, MAC address, pembentukan frame
Physical Media transmisi seperti kabel UTP, wireless, maupun Fiber Optik

Model OSI bekerja seperti berikut ini :
  1. Informasi dikirim dengan cara dikirim mulai dari layer application turun sampai layer physical.
  2. Kemudian dikirimkan melewati media (kabel, wireless) sampai ke tujuan.
  3. Setelah sampai, informasi di proses naik dari layer physical sampai ke layer application.

Layer Application

Layer 7 (application) penyerangan interface yang digunakan oleh aplikasi/program/software untuk berkomunikas. Berikut adalah beberapa layanan dan protokol yang bisa dibilang “tidak aman” :
  • FTP, layanan TCP yang beroperasi pada port 20 dan 21. Port 20 digunakan untuk transfer data klien dan server, sedangkan port 21 digunakan untuk control dan pengiriman command antara klien dan FTP server. Serangan pada layanan ini bisa berupa eksploitasi kesalahan konfigurasi directory permission dan atau sniffing password yang berbentuk cleartext.
  • Telnet, layanan shell pada TCP yang beroperasi pada port 23. Telnet mengirimkan informasi yang kita ketikkan di klien kepada komputer lain. Telnet bisa diatur untuk koneksi secara anonymous dan bisa juga diatur agar menggunakan username dan password. Kelemahan telnet adalah semua data termasuk username dan password dikirim dalam bentuk cleartext.
  • SMTP, layanan TCP yang beroperasi pada port 25 dan berfungsi untuk menjalankan proses pertukaran email antar sistem network. Pesan yang dikirim melalui SMTP memiliki 2 bagian, address header dan pesan text. Semua jenis komputer dapat bertukar pesan email dengan SMTP. Dua jenis serangan SMTP yang cukup beresiko adalah spoofing dan spamming.
  • DNS, layanan ini berjalan pada port 53 dan berfungsi untuk melakukan address mapping. DNS mengkonversi Fully Qualified Domain Names (FQDNs) seperti www.google.com ke bentuk IP address dan sebaliknya. DNS menggunakan UDP untuk DNS query dan TCP untuk zone transfers. DNS rawan oleh serangan poisoning dan jika salah konfigurasi dapat disalahgunakan untuk melakukan zone full transfer.
  • TFTP, beroperasi pada port 69, merupakan versi FTP yang menggunakan UDP untuk mengurangi overhead dan reliability dengan menghilangkan proses session management dan autentikasi, hal ini menimbulkan resiko keamanan yang cukup tinggi. TFTP biasa digunakan untuk mengirim file-file konfigurasi router dan untuk mengkonfigurasi kabel modem. Orang yang melakukan hacking pada kabel modem biasa dikenal sebagai uncapper.
  • HTTP, layanan TCP yang beroperasi pada port 80 ini membuat web menjadi layanan paling populer saat ini. HTTP menggunakan protokol request response, dimana klien mengirimkan request kemudian server memberikan response. Serangan pada HTTP bisa ditujukan ke server, browser, atau script-script yang berjalan pada browser.
  • SNMP, layanan UDP yang beroperasi pada port 161 dan 162, SNMP didesain sebagai cara yang efisien dan murah untuk memonitor network. Protokol SNMP memungkinkan perangkat-perangkat jaringan yang berfungsi sebagai agent untuk mengumpulkan berbagai macam informasi dan mengirimkannya ke server management. Hal yang membuat SNMP kurang aman adalah proses pengiriman community string yang masih dalam bentuk clear-text. SNMP versi 3 merupakan versi terbaru dan menawarkan fitur enkripsi agar lebih aman.

Layer Transport

Layer transport penuh dengan lubang keamanan karena merupakan tempat bagi UDP dan TCP. Karena UDP bersifat connectionless, mudah bagi hacker untuk melakukan serangan DoS (Denial of Service). Selain itu juga mudah untuk melakukan spoofing. Sedangkan TCP dapat dieksploitasi oleh hacker untuk mengidentifikasi berbagai macam layanan yang berjalan dan sistem operasi yang digunakan oleh target. Hal ini penting bagi hacker sebelum melakukan serangan.

Layer Network

Pada layer ini terdapat IP dan ICMP. IPv4 tidak memiliki built-in fitur security, karenanya IPSec yang merupakan komponen built-in dikembangkan. Tanpa IPSec, IP dapat dengan mudah menjadi target bagi berbagai macam serangan. Sedangkan ICMP dapat menjadi target bagi serangan Smurf DoS.

Layer Data Link

Konversi pengalamatan logik (IP) ke physical (MAC) harus dilakukan antara layer network dan layer data link. Protokol ARP digunakan untuk hal ini. Namun, ARP sering dimanfaatkan oleh hacker untuk melakukan ARP poisoning, sehingga hacker dapat mem-bypass switch dan monitor traffic. Selain itu, passive sniffing dapat menjadi metode bagus bagi hacker jika ia berada pada posisi yang strategis didalam network.

Layer Physical

Layer physical ini adalah layer yang paling mudah untuk “dibobol“. Logika sederhananya adalah jika seseorang mendapatkan akses secara fisik ke sebuah perangkat jaringan, tentunya dia juga bisa mendapatkan kendali penuh terhadap perangkat tersebut. Beberapa vendor perangkat jaringan juga menyediakan metode melakukan reset password untuk mendapatkan akses ke perangkat tersebut.

Layer Manusia

Layer ini tidak termasuk dalam susunan Model OSI. Namun layer ini bisa kita tambahkan sebagai layer terpenting dalam desain dan implementasi jaringan. Begitu pula dalam hal keamanan, layer ini memiliki ancaman terbesar yang dikenal sebagai social engineering, karena targetnya adalah manusia (admin, dan lain-lain). Pada umumnya organisasi membelanjakan anggaran yang cukup besar dalam bidang kontrol dan teknis, namun sangat sedikit anggaran yang dikeluarkan untuk pendidikan/pelatihan proses dan prosedur keamanan bagi karyawannya. Hacker dapat menggunakan berbagai macam teknik untuk melakukan tipu muslihat pada karyawan.
Ancaman lain pada layer ini adalah dumpster diving. Banyak perusahaan yang “membuang” berbagai macam hal yang terlihat tidak berguna tapi dapat dimanfaatkan oleh hacker sebagai alat untuk mengorek informasi tentang network internal. Misalnya, printout nama dan password, source code, memo, dan lain-lain.

Demikian Jenis-jenis serangan pada Jaringan Komputer. Maka sebagai orang yang berkecimpung di dalam jaringan komputer itu harus tahu serangan apa saja yang dilakukan oleh para hacker agar kita bisa mencegahnya dengan cepat dan tepat. Semoga bermanfaat bagi sobat blogger ^_^

sumber : http://net.comlabs.itb.ac.id/blog/?p=425

Read More

Minggu, 24 November 2013

Cara konfigurasi OSPF pada Router Cisco

  1 komentar
11/24/2013 09:16:00 AM

Cara Konfigurasi OSPF pada Router Cisco - Salam sobat blogger, sudah lama tidak posting kembali di blog tercinta. Hari ini santekno akan memposting tentang cara konfigurasi routing protocol OSPF pada router Cisco dengan menggunakan Packet Tracer 6.

Teman-teman pasti sudah tahu routing dinamic OSPF ini, karena terkenal sekali di kalangan jaringan komputer karena routing protokol ini open source dan bisa digunakan pada router apapun dari mulai Router Cisco, Mikrotik, dan Juniper. Karena berbagai keunggulan yang ada pada OSPF maka routing protokol ini sangat mudah digunakan dan banyak sekali orang menggunakan routing protokol ini.


OSPF Router

OSPF ini selain digunakan pada jaringan kecil tetapi bisa juga digunakan pada jaringan MAN (Metropolitan Area Network) yang lebih cepat untuk konvergensinya. Sehingga sobat blogger yang berkecimpung dalam dunia jaringan perlu paham tentang konfigurasi OSPF dari dasar sampai konfigurasi yang lebih komplek lagi.

Santekno akan memberikan tutorial tentang konfigurasi Router secara rinci dan konfigurasi yang santekno tutorialkan ini masih sederhana dan topologinya pun masih sederhana sehingga gampang untuk dipahami. Agar sobat bisa mengerti silahkan lihat video YouTube yang ada di bawah ini.


Sudah paham sekarang?? bagi sobat blogger bagi yang mau lebih lanjut memahami bagaimana cara konfigurasi OSPF pada router Cisco, Santekno sertakan file simulasi dari packet tracer dan bisa di download secara gratis. Silahkan saja.

DOWNLOAD KONFIGURASI OSPF

Sekian dulu postingan tentang Cara Konfigurasi OSPF pada Router Cisco, semoga bermanfaat bagi sobat blogger. ^_^

Read More

Rabu, 13 November 2013

Cara Konfigurasi EIGRP pada Router Cisco

  1 komentar
11/13/2013 12:17:00 PM

Cara Konfigurasi EIGRP pada Router Cisco - Salam sobat blogger, kali ini Santekno akan menjelaskan tentang konfigurasi EIGRP (Enhanced Interior Gateway Routing Protocol) dengan mudah dan secara bertahap. Sobat blogger gampang sekali apabila ingin melakukan konfigurasi routing protokol EIGRP pada router Cisco.

Kenapa router Cisco? Karena fasilitas routing protokol EIGRP itu hanya ada di perangkat CISCO saja, dan di perangkat lain tidak digunakan. Karena terbilang sangat baik untuk menghubungkan topologi jaringan dan cepat maka EIGRP ini lebih baik dibandingkan dengan RIP yang mempunyai beberapa kelemahan.

Konfigurasi EIGRP

Bagaimana Dengan routing Protokol OSPF (Open Shortest Path First)? Itu hampir sama kecepatan dalam hal convergensi terhadap topologi jaringan. Yang membedakan dari EIGRP dan OSPF yaitu dari segi perangkat EIGRP hanya bisa berjalan atau melakukan routing di perangkat CISCO saja jadi jika terhubung dengan perangkat lain maka routing tersebut tidak berjalan, sedangkan OSPF bisa di jalankan di berbagai perangkat jaringan karena OSPF itu merupakan aplikasi routing yang Open Source.

Langsung saja pada konfigurasi, berikut bagi sobat yang ingin lebih mempelajari konfigurasi EIGRP secara mendalam lihat video dibawah ini agar lebih paham dalam aplikasinya.


Santekno juga menyertakan packet tracernya jika kalian memerlukannya, silahkan saja download link yang ada di bawah ini ya.


DOWNLOAD KONFIGURASI EGRP
 
Beberapa konfigurasi pada router seperti dibawah ini :
Konfigurasi Pada Router R1
Konfigurasi Pada Router R2
Konfigurasi Pada Router R3

Demikian Tutorial Cara Konfigurasi EIGRP pada Router Cisco, semoga bermanfaat bagi sobat ya, terus kunjungi Santekno karena nanti akan ada update terbaru mengenai Jaringan Komputer. ^_^

Read More

Kamis, 31 Oktober 2013

Cara Konfigurasi RIP pada Router Cisco

  Tidak ada komentar
10/31/2013 07:54:00 PM

Cara Konfigurasi RIP v2 pada Router Cisco dengan Packet Tracer - Salam sobat, Santekno saat ini akan menjelaskan tentang bagaimana cara konfigurasi RIP yaitu dynamic protocol yang biasa kita gunakan pada LAN atau sering dipakai pada topologi yang sangat simple karena protokol RIP ini hanya bisa berjalan pada 15 Router saja selebihnya RIP akan tidak berjalan dan berkerja sangat lambat.

Topologi RIP v2

Pada kali ini Santekno, menyertakan file konfigurasi pada Packet Tracer Cisco sehingga bagi sobat bisa diunduh dan dipelajari sebih detail untuk latihan-latihan dasar Jaringan Komputer khususnya konfigurasi Router Cisco.

Silahkan download file .pkt di bawah ini ;



Nah, Santekno juga memberikan tutorial video di Youtube, jadi sobat tinggal melihat bagaimana cara konfigurasinya dan terapkan langsung pada latihan pada file yang sudah di sertakan.



Jika sobat bingung, Santekno akan memperlihatkan konfigurasi pada router-router yang ada pada gambar di atas dengan konfigurasi yang simple dan mudah untuk dipahami, Berikut ini konfigurasinya.

Konfigurasi pada R1
=======================================
R1>enable
R1#configure terminal
R1(config)#router rip
R1(config-router)# version 2 
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.4.0

Konfigurasi pada R1
=======================================
R2>enable
R2#configure terminal
R2(config)#router rip
R2(config-router)# version 2 
R2(config-router)# network 192.168.4.0
R2(config-router)# network 192.168.2.0
R2(config-router)# network 192.168.5.0

Konfigurasi pada R1
=======================================
R3>enable
R3#configure terminal
R3(config)#router rip
R3(config-router)#version 2 
R3(config-router)# network 192.168.5.0
R3(config-router)# network 192.168.3.0

Demikian Cara Konfigurasi RIP pada Router Cisco semoga bermanfaat bagi sobat, jika masih bingung atau ingin mempelajari lebih lanjut tentang Jaringan Komputer, tetap kunjugin Santekno.blogspot.com nanti akan memberikan informasi terupdate tentang konfigurasi router khususnya Cisco. Terimakasih sobat ^_^

Read More

Jumat, 25 Oktober 2013

Cara Konfigurasi Static Route pada Router Cisco

  5 komentar
10/25/2013 12:28:00 AM

Cara Konfigurasi Static Route pada Router Cisco - Hai sobat kali ini Santekno akan menjelaskan tentang Static Route. Postingan yang terdahulu memang sudah menjelaskan lebih detail tentang pengenalan, pengertian dari Static Route. Bahkan Santekno telah menjelaskan perbedaan dari Static Route dengan Dynamic Route.

Kali ini, Santekno akan menjelaskan konfigurasinya pada router cisco tetapi tidak langsung kedalam router cisco hanya pada simulasi packet tracer yang sudah dipelajari. Sebenarnya sama saja kita simulasi dalam packet tracer atau langsung juga karena sintaknya sama saja dari kedua-duanya.

Topologi yang Static Route
Diatas adalah topologi static route yang sangat sederhana oleh Santekno buat, agar lebih simple dan gampang untuk dipahami oleh sobat semua. Berikut ini adalah konfigurasi pada beberapa router diatas.
R1
R1(config)# ip route 192.168.2.0 255.255.255.0 Fa0/0
R1(config)# ip route 192.168.3.0 255.255.255.0 Fa0/0
R1(config)# ip route 192.168.4.0 255.255.255.0 Fa0/0
R2
R2(config)# ip route 192.168.1.0 255.255.255.0 Fa0/0
R2(config)# ip route 192.168.3.0 255.255.255.0 Fa0/1
R3
R3(config)# ip route 192.168.1.0 255.255.255.0 Fa0/1
R3(config)# ip route 192.168.4.0 255.255.255.0 Fa0/1
R3(config)# ip route 192.168.2.0 255.255.255.0 Fa0/1

Bagi Sobat yang ingin mendownload simulasi pada Packet Tracer Santekno ini sudah menyiapkannya.


Nah, jika sobat ingin mendalami agar lebih paham Santekno memberikan beberapa Tutorial berupa Video, berikut ini video tutorial yang sudah Santekno berikan.


Demikian tutorial Cara Konfigurasi Static Route pada Router Cisco. Semoga bermanfaat ya bagi sobat semuanya, Jika ada pertanyaan silahkan komentar saja. ^_^

Read More

Rabu, 16 Oktober 2013

Cara Memberi Password Telnet dan Console pada Router Cisco

  4 komentar
10/16/2013 09:49:00 PM

Cara Memberi Password Telnet dan Console pada Router Cisco - Salam teman-teman, kali ini Santekno akan menjelaskan mengenai Networking atau Jaringan Komputer. Dan pada saat ini Santekno akan lebih menjelaskan kepada Keamanan dalam suatu jaringan dimulai dari device sendiri sampai pada Firewall yang akan nanti diterapkan.

Password Telnet dan Console pada Router Cisco


Secara umum, keamanan dalam suatu jaringan itu sangat perlu sekali karena untuk menyelamatkan data kita yang ada di server dan agar terhindar dari para hacker yang mencoba masuk kedalam suatu private network kita yang biasanya tidak boleh diakses dalam remote dari public. Maka dari itu secara mendasar Santekno akan menjelaskan bagaimana pemberian Password Telnet dan Console agar tidak sembarang orang bisa masuk dan konfigurasi ke dalam router kita.

Cara konfigurasi pada Router itu terbagi menjadi 2 yaitu melewati Console dan menggunakan Telnet. Pemberian password pada console yaitu pemberian keamanan untuk Router yang langsung terhubung ke Router tersebut menggunakan kabel console, sedangkan Telnet yaitu mengkonfigurasikan Router secara remote atau secara tidak langsung terhubung ke routernya, seperti bisa melalui jaringan IP public atau internet.

Baiklah, pertama kali kita akan mencoba memberikan password pada Router terlebih dahulu. Berikut adalah konfigurasinya:

Router>enable
Router#configure terminal
Router(config)#enable password santekno
Router(config)#enable secret santekno

Tulisan yang berwarna merah merupakan password yang nanti jika masuk ke dalam router tersebut pada mode #. enable password dan secret sama saja tetapi mempunyai perbedaan yaitu jika menggunakan password maka password router tersebut tidak di enskripsi sedangkan jika menggunakan secret maka password yang sudah di konfigurasikan akan di enskripsi seperti gambar dibawah ini 

Perbedaan password dan secret

Nah setelah itu kita akan memberikan password pada Console jika akan melakukan konfigurasi pada Router Cisco. berikut cara konfigurasinya :

R1>enable
R1#config terminal
R1(config)# line con 0
R1(config-line)# password santekno
R1(config-line)# login

Sedangkan konfigurasi password untuk Telnet pada Router Cisco sebagai berikut :

R1>enable
R1#config terminal
R1(config)# line vty 0 4
R1(config-line)# password santekno
R1(config-line)# login

Bagaimana cukup mudah kan untuk pemberian keamanan dalam Router? Keamanan dalam suatu jaringan itu harus dimulai dari yang terkecil seperti pemberian password console, Telnet dan juga password Routernya.
Sekian penjelasan mengenai Cara Memberi Password Telnet dn Console pada Router Cisco, Semoga bermanfaat bagi sobat. ^_^

Read More

Selasa, 06 Agustus 2013

Pengertian VLAN (Virtual LAN)

  Tidak ada komentar
8/06/2013 08:46:00 PM

Pengertian VLAN (Virtual LAN) - Pada kesempatan kali ini Santekno akan membahas lagi mengenai pengetahuan Networking yang mendasar seperti VLAN yang sudah biasa para engginer konfigurasikan agar suatu switch bisa digunakan untuk membagi network yang berbeda dalam satu jaringan lokal. Seperti kita ketahui bahwa switch tidak bisa membaca Layer 3 sehingga tidak bisa membaca Network sehingga hanya bisa dihubungkan hanya satu network saja.

Dengan dikeluarkannya VLAN maka sangat bermanfaat sekali untuk kemajuan pembagian Network agar lebih efisien. Pengertian dari VLAN (Virtual LAN) adalah suatu model jaringan yang tidak terbatas pada lokasi fisik seperti LAN, hal ini mengakibatkan suatu network dapat dikonfigurasi secara virtual tanpa harus menuruti lokasi fisik peralatan. Penggunaan VLAN akan membuat pengaturan jaringan menjadi sangat fleksibel karena dapat dibuat segmen yang bergantung pada organisasi, tanpa bergantung lokasi workstations.

Contoh Pembagian VLAN


VLAN diciptakan untuk menyediakan layanan segmentasi secara tradisional disediakan oleh router di konfigurasi LAN. VLAN menangani masalah-masalah seperti skalabilitas, keamanan, dan manajemen jaringan.

Kegunaan VLAN
  • Menimalisir kemungkinan terjadinya konflik IP yang terlalu banyak.
  • Mencegah terjadinya collision domain (tabrakan domain).
  • Mengurangi tingkat vulnerabilities.

Cara Kerja VLAN

VLAN diklasifikasikan berdasarkan metode (tipe) yang digunakan untuk mengklasifikasikannya, baik itu menggunakan port, MAC address, dsb. Semua informasi yang mengandung penandaan/pengalamatan suatu VLAN (tagging) disimpan pada suatu database, jika penandaannya berdasarkan port yang digunakan maka database harus mengindikasi port-port yang digunakan VLAN.

Untuk mengaturnya maka biasanya digunakan switch yang bisa diatur. Switch/bridge inilah yang bertanggung jawab menyimpan semua informasi dan konfigurasi suatu VLAN dan dipastikan semua switch memiliki informasi yang sama.

VLAN Cross Connect (CC) adalah mekanisme yang digunakan untuk membuat VLAN Switched, VLAN CC menggunakan frame IEEE 802.1ad mana Tag S digunakan sebagai Label seperti dalam MPLS. IEEE menyetujui penggunaan seperti mekanisme dalam nominal 6,11 dari IEEE 802.1ad-2005.

Kesimpulannya, VLAN membuat kita dapat mengontrol pola lalu lintas dan bereaksi cepat untuk relokasi. VLAN memberikan fleksibilitas untuk beradaptasi dengan perubahan dalam persyaratan jaringan dan memungkinkan untuk administrasi disederhanakan.

Apa Kelemahan dari VLAN ?
  • Secara logika berbeda network tetapi secara fisik satu network
  • Ketika ada broadcast jadi semua dikirim ke semua
  • ketika jumlah banyak host-nya maka kerja DHCP akan berantakan dan tidak bisa diduga.
Kenapa harus menggunakan VLAN?
  • Jika dalam jumlah yang banyak dalam satu network maka akan terganggu (gampang terserang hack)
  • Keamanan menjadi baik karena fisik satu network tetapi logic berbeda network
  • Masalah kebutuhan
  • Router itu kerjanya lebih lambat ketimbang switch
  • Dengan VLAN broadcast akan di batasi
  • Untuk membedakan VLAN satu denngan VLAN yang lain dengan menggunakan ID
  • Contohnya port 1-5 masuk ke VLAN1
  • VLAN dengan bentuk Number Angka
  • Contoh VLAN10 -> Sales

Jenis-jenis VLAN dalam Switch
  1. VLAN default adalah VLAN yang sudah ada secara default contoh di cisco VLAN1,VLAN1002
  2. Data VLAN adalah VLAN yang digunakann oleh user
  3. VLAN VOIP adalah dikhususkan untuk komunikasi suara dan akan memberikan prioritas utama dibandingkan datanya
  4. VLAN Native  
  5. VLAN management adalah VLAN yang dibangun keperluan management switch, misalnya : akan mengubah konfigurasi switch Admin, dan Admin dimasukkan ke VLAN management artinya hanya orang-orang yang keperluan khusus

Jalur VLAN ada 2 bentuk
  1. Tradisional jadi mempunyai banyak jalur
  2. TRUNKING yaitu VLAN yang mempunyai 1 jalur mempunyai teks yang mengidentifikasikan beberapa VLAN atau jalurnya mempunyai banyak jalur logika dlam 1 fisik
2 Port yang biasa digunakan
  1. Port Access = port menghubungkan ke PC (Data user)
  2. Port Trunking = port yang menghubungkan antar SWITCH

Nah sekarang sudah mengetahui bagaimana suatu VLAN bisa digunakan. Tinggal dipraktikan saja dalam packet tracer konfigurasinya. Agar Kalian lebih mengerti mengenai Cara Konfigurasi VLAN dalam Packet Tracer tinggal lihat saja postingan Santekno Selanjutnya. Demikian penjelasan mengenai Pengertian VLAN (Virtual LAN). Semoga bermanfaat bagi teman-teman semua ^_^

Read More

Kamis, 20 Juni 2013

Pengertian dan Konfigurasi DHCP pada Router Cisco

  17 komentar
6/20/2013 10:30:00 PM

NetworkPengertian dan Konfigurasi DHCP (Dynamic Host Configuration Protocol) pada Router Cisco adalah protocol yang berbasis arsitektur client/server yang digunakan untuk memudahkan pengalokasian alamat IP dalam satu jaringan. ISP secara otomatis akan memberikan alamat IP baru kepada komputer yang memintanya. Komputer yang meminta alamat IP disebut DHCP Client sedangkan Komputer yang memberikan alamat IP disebut DHCP server. Ketika konfigurasi TCP/IP, administrator tidak perlu memberikan alamat IP secara manual, tapi cukup dengan memberikan referensi kepada DHCP Server.

Ketika kedua DHCP client dihidupkan, maka komputer tersebut melakukan permintaan ke DHCP-Server untuk memperoleh alamat IP. Kemudian DHCP akan merespon dengan memberikan alamat IP yang ada di database DHCP. Setelah DHCP Server memberikan alamat IP, maka server meminjamkan (lease) alamat IP yang ada ke DHCP Client dan mencoret nomor IP tersebut dari daftar pool. Alamat IP diberikan bersama dengan subnet mask dan default gateway. Apabila tidak terdapat lagi alamt IP yang bisa diberikan, maka client tidak akan bisa menginisialisasi TCP/IP, sehingga tidak bisa tersambung dengan jaringan tersebut.
               
Pemakaian DHCP Client tersebut dinyatakan selesai setelah periode waktu tertentu, sehingga client tidak memperbaharui permintaannya lagi, dan alamat IP tersebut dikembalikan kepada DHCP Server sehingga server dapat memberikan nomor IP tersebut kepada Client yang memerlukan. Jangka waktu periode ini bisa ditentukan dalam hitungan menit, jam, bulan atau selamanya. Jangka waktu tersebut disebut leased period.

Kelebihan Dynamic Host Configuration Protocol


  • Memudahkan dalam transfer data kepada PC client lain atau PC server.
  • DHCP menyediakan alamat-alamat IP secara dinamis dan konfigurasi lain. DHCP ini didesain untuk melayani network yang besar dan konfigurasi TCP/IP yang kompleks.
  • DHCP memungkinkan suatu client menggunakan alamat IP yang reusable, artinya alamat IP tersebut bisa dipakai oleh client yang lain jika client tersebut tidak sedang menggunakannya (off).
  • DHCP memungkinkan suatu client menggunakan satu alamat IP untuk jangka waktu tertentu dari server.
  • DHCP akan memberikan satu alamat IP dan parameter-parameter kofigurasi lainnya kepada client.

Konfigurasi  Dynamic Host Configuration Protocol

Asumsi:
IP FastEthernet : 192.168.10.1
Network : 192.168.10.0
Netmask : 255.255.255.0



Router>enable
Router#configure terminal
Router(config)#ip dhcp pool aris
Router(dhcp-config)#network 192.168.10.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.10.1
Router(dhcp-config)#dns-server 8.8.8.8
Router(dhcp-config)#exit


Setelah konfigurasi yang diatas sudah dilakukan pada Router Cisco. Maka tinggal pengecekan pada komputer atau PC yang sudah terhubung langsung dengan cara klik PC—> Deskstop, maka akan muncul seperti gambar di bawah


selanjutnya klik IP Configuration, ubah IP Static menjadi DHCP, maka jika berhasil dengan sendirinya IP 


PC atau Laptop akan terisi sendiri dengan status DHCP request successfull


jika sudah berhasil, lakukan langkah yang sama ke pada masing masing PC


Demikian penjelasan mengenai Pengertian dan Konfigurasi DHCP (Dynamic Host Configuration Protocol)pada Router Cisco. Semoga bermanfaat ya teman-teman ^__^


Referensi :
http://cpu-speed.com/index.php/artikel/komputer/tutorial/4-pengertian-dhcp
http://temukanpengertian.blogspot.com/2013/06/pengertian-dhcp.html
http://hadi27.wordpress.com/pengertian-dan-kelebihan-dhcp/
http://blog.arisst.com/2012/06/cara-setting-dhcp-di-router-cisco.html

Read More

Kamis, 13 Juni 2013

Pengertian NAT dan Cara Konfigurasi pada Router Cisco

  16 komentar
6/13/2013 05:22:00 PM

NetworkPengertian NAT dan Cara Konfigurasi pada Router Cisco Saat ini, protokol IP yang banyak digunakan adalah IP versi 4 (IPv4). Dengan panjang alamat 4 byte berarti terdapat 2 pangkat 32 = 4.294.967.296 alamat IP yang tersedia. Jumlah ini secara teoritis, jumlah komputer yang dapat langsung koneksi ke internet. Karena keterbatasan ini sebagian besar ISP (Internet Service Provider) hanya akan mengalokasikan satu alamat untuk satu pengguna dan alamat ini bersifat dinamik, dalam arti alamat IP yang diberikan akan berbeda setiap kali user melakukan koneksi ke Internet. Di satu sisi mereka membutuhkan banyak komputer yang terkoneksi ke internet, akan tetapi di sisi lain hanya tersedia satu alamat IP yang berarti hanya ada satu komputer yang bisa terkoneksi ke internet. Hal ini bisa diatasi dengan metode NAT. Dengan NAT gateway yang dijalankan di salah satu komputer, satu alamat IP tersebut dapat dibagi ke beberapa komputer yang lain dan mereka bisa melakukan koneksi ke internet secara bersamaan.

IP address private tidak bisa di route ke internet (non-routed), hanya dipakai pada
jaringan internal yang berada pada range berikut:

Class Type
Start Address
End Address
Class A
10.0.0.0
10.255.255.254
Class B
172.16.0.0
172.31.255.254
Class C
192.168.0.0
192.168.255.254
     
Untuk setiap paket yang dihasilkan oleh client, implementasi Network Address Translation
(NAT) menggantikan IP address yang terdaftar kepada IP address client yang tidak terdaftar.

NAT adalah suatu metode untuk menghubungkan lebih dari satu komputer ke jaringan internet dengan menggunakan satu alamat IP. Banyaknya penggunaan metode ini disebabkan karena ketersediaan alamat IP yang terbatas, kebutuhan akan keamanan (Security), kemudahan serta fleksibilitas dalam administrasi jaringan.

NAT merupakan salah satu protocol dalam suatu sistem jaringan, NAT memungkinkan suatu jaringan dengan IP atau internet protocol yang bersifat privat IP belum teregistrasi di jaringan internet untuk mengakses jalur internet, hal ini berarti suatu alamat IP dapat mengakses internet dengan menggunakan IP Privat atau bukan menggunakan IP Public, NAT biasanya dibenamkan dalam sebuah router, NAT juga sering digunakan untuk menggabungkan atau menghubungkan dua jaringan yang berbeda, dan mentranslate atau menterjemahkan IP Privat dalam jaringan internal ke dalam jaringan yang legal network sehingga memiliki hak untuk melakukan akses data dalam sebuah jaringan.

Jenis-jenis NAT
1)      Full cone NAT
2)       Restricted cone NAT

3)       Port restricted cone NAT

4)      Symmetric NAT


TIPE-TIPE NAT

A. NAT Tipe Statis
NAT Statis menggunakan table routing yang tetap, atau alokasi translasi alamat ip ditetapkan sesuai dengan alamat asal atau source ke alamat tujuan atau destination, sehingga tidak memungkinkan terjadinya pertukaran data dalam suatu alamat ip bila translasi alamat IPnya belum didaftarkan dalam table NAT. NAT Statia terjadi ketika sebuah alamat lokal (inside) di petakan ke sebuah alamat global/internet (outside). Alamat lokal dan global dipetakan satu lawan satu secara statik. NAT secara statis akan melakukan request atau pengambilan dan pengiriman paket data sesuai dengan aturan yang telah ditabelkan dalam sebuah NAT
.
B. NAT Tipe Dinamis
NAT dengan tipe dinamis menggunakan logika balancing atau menggunakan logika pengaturan beban, di mana dalam tabelnya sendiri telah ditanamkan logika kemungkinan dan pemecahannya, NAT dengan tipe dinamis pada umumnya dibagi menjadi 2 jenis yaitu NAT sistem pool dan NAT sistem overload.

C. NAT Sistem Pool
NAT dengan sistem pool atau kelompok menggunakan sebuah tabel NAT dengan logika dinamis, dimana logika yang ditanamkan dalam NAT tersebut pada umumnya merupakan logika Fuzzy atau jika lambang yang nilai translasinya belum pasti, dalam sistem pool suatu request belum tentu akan melewati jaringan yang sama bila melakukan request yang sama untuk kedua kalinya, Translasi Dinamik terjadi ketika router NAT diset untuk memahami alamat lokal yang harus ditranslasikan, dan kelompok (pool) alamat global yang akan digunakan untuk terhubung ke internet. NAT dengan sistem pool biasanya sering dimanfaatkan untuk melakukan balancing atau penyeimbangan beban pada jaringan.

D. NAT Sistem Overload
NAT dengan sistem Overloading menggunakan logika request atau permintaan dari banyak client atau banyak alamat dioperkan atau diberikan ke satu alamat IP distribusi. Sejumlah IP lokal/internal dapat ditranslasikan ke satu alamat IP global (outside). Sejumlah IP Lokal /internal dapat ditranslasikan ke satu alamat IP global (outside). Hal ini sangat menghemat penggunakan alokasi IP dari ISP. Sharing/pemakaian bersama satu alamat IP ini menggunakan metoda port multiplexing, atau perubahan port ke packet outbound.

Penggabungan sistem overloading dan sistem pool telah dilakukan oleh banyak produsen router dan menghasilkan logika yang banyak digunakan untuk load balancing saat ini yaitu Round Robbin Load Balancing, dimana logika ini melakukan pengiriman request secara berurutan, secara bergantian ke alamat gateway yang telah ditanamkan dalam tabel NAT sebelumnya, sehingga suatu multirequest dari sebuah alamat IP dapat melalui lebih dari satu alamat distribusi, penerapan ini dapat dilakukan dalam penggunaan Dual Wan Router, selain itu logika ini juga memiliki logika Fail Over, dimana bila suatu alamat distribusi tidak dapat lagi mengirimkan paket maka paket akan dialihkan ke alamat distribusi yang lain.

KONFIGURASI NAT

Saat ini Santekno akan menjelaskan cara mengkonfigurasi NAT menggunakan Cisco 3640.
Ini contoh saja biar bisa terbayangkan konfigurasi di Router Cisco untuk penerapan NAT. Berikut konfigurasinya :
1. FastEthernet1 (f0/0) dengan IP 192.168.1.0. Interface ini terhubung ke jaringan yang akan di NAT
2. Serial 0/0/0 dengan IP 200.200.200.1. Interface ini terhubung ke internet. Masuk ke mode privileged config t


Router# configure terminal
Router(config)# interface fa0/0 (IP Private)
Router(config-if)# ip add 192.168.0.1 255.255.255.0

Router(config)# interface s0/0/0 (IP Public)
Router(config-if)# ip add 200.200.200.1 255.255.255.0

Interface diatas terhubung ke jaringan yang akan di NAT.

Konfigurasi access list untuk digunakan dalam proses NAT

HQ(config)# access-list 1 permit 192.168.1.0 0.0.0.255

Konfigurasi router agar NAT semua paket dari IP Private 192.168.1.0 ke dalam IP Public 200.200.200.2 - 6

HQ(config)# ip nat pool INTERNET 200.200.200.2 200.200.200.6 netmask 255.255.255.248
HQ(config)# ip nat inside source list 1 pool INTERNET overload



Pilih interface yang langsung terhubung dengan NAT, dan definisikan network pada jaringan ini sebagai network yang akan di NAT.

HQ(config)# int f0/0
HQ(config)# ip nat inside
HQ(config)# ip s0/0/0
HQ(config)# ip nat outside



Bagi sobat yang ingin mempelajari lebih baik lagi Santekno sertakan .pkt nya silahkan tinggal download saja.


Konfigurasi selesai. Cek apakah host pada jaringan 192.168.1.0 dapat terhubung ke internet. Cek juga konfigurasi NAT pada router dengan perintah
show ip nat translation. Demikian Pengertian NAT (Network Address Translation) dan Cara Konfigurasinya, semoga postingan Santekno bermanfaat.


Jika ingin lebih paham lagi silahkan lihat tutorial yang ada di video ini :



Referensi :

http://tttahu.blogspot.com/2013/01/pengertian-network-address-translation.html
http://www.jejaring.web.id/pengertian-nat-dan-tipe-tipe-nat/
http://tttahu.blogspot.com/2013/01/pengertian-network-address-translation.html
http://ardisragen.net/konfigurasi-nat-pada-router-cisco.html

Read More

Senin, 15 April 2013

Pengertian PPP (Point to Point Protocol)

  2 komentar
4/15/2013 07:14:00 PM

Network - Point-to-Point Protocol (sering disingkat menjadi PPP) adalah sebuah protokol enkapsulasi paket jaringan yang banyak digunakan pada wide area network (WAN). Protokol ini merupakan standar industri yang berjalan pada lapisan data-link (layer 2)  dan dikembangkan pada awal tahun 1990-an sebagai respons terhadap masalah-masalah yang terjadi pada protokol Serial Line Internet Protocol (SLIP), yang hanya mendukung pengalamatan IP statis kepada para kliennya. Dibandingkan dengan pendahulunya (SLIP), PPP jauh lebih baik, mengingat kerja protokol ini lebih cepat, menawarkan koreksi kesalahan, dan negosiasi sesi secara dinamis tanpa adanya intervensi dari pengguna. Selain itu, protokol ini juga mendukung banyak protokol-protokol jaringan secara simultan.
Point to Point

PPP Komponen dan Fitur

PPP menyediakan metode untuk transmisi datagram lebih link point-to-point serial. PPP terdiri dari tiga komponen utama:
  • Sebuah metode untuk encapsulating datagrams atas link serial.
  • PPP menggunakan Tingkat Tinggi Data Link Control (HDLC) protokol sebagai dasar untuk encapsulating datagrams lebih link point-to-point.
  • Sebuah LCP extensible untuk membangun, mengkonfigurasi, dan menguji koneksi data link.
  • Sebuah keluarga NCPs untuk menetapkan dan mengkonfigurasi protokol jaringan lapisan yang berbeda.
  • PPP protocol beroperasi melalui koneksi interface piranti Data Communication Equipment (DCE) dan piranti Data Terminal Equipment (DTE).
  • PPP protocol dapat beroperasi pada kedua modus synchronous (dial-up) ataupun asynchronous dan ISDN.
  • Tidak ada batas transmission rate
  • Keseimbangan load melalui multi-link
  • LCP dipertukarkan saat link dibangun untuk mengetest jalur dan setuju karenanya
  • PPP protocol mendukung berbagai macam protocol layer diatasnya seperti IP; IPX; AppleTalk dan sebagainya.
  • PPP protocol mendukung authentication kedua jenis clear text PAP (Password Authentication Protocol) dan enkripsi CHAP (Chalange Handshake Authentication Protocol)
  • NCP meng-encapsulate protocol layer Network dan mengandung suatu field yang mengindikasikan protocol layer atas
PPP mengandung Header yang mengindikasikan pemakaian protocol layer Network.PPP protocol Link Control Protocol (LCP) merupakan satu set layanan yang melaksanakan setup link dan memiliki Fase sebagai berikut :
  • Link Entablisment and Negotiation, mencoba untuk membentuk link dengan router lawan (pembentukan link) request link dan router tetangga mengirim acnowlegment dengan isi [setuju atau tidak]. Pada fase ini akan menawarkan opsi :
    • Authentication, mengirim dalam persetujuan PAP atau CHAP
    • Compression, setiap mengirim dalam bentuk di kompres atau tidak
    • Multilink, dalam satu interface dalpat membuat beberapa virtual link
  • Determination Link Qualitiy, menentukan kualitas linknya (optional)
  • NCP (Network Control Protocol) berfungsi mengontrol establisment

PPP protocol dapat berjalan pada bermacam-macam standard physical synchronous dan asynckronous termasuk :
  • Serial Asynchronous seperti dial-up
  • ISDN
  • Serial synchronous
  • HIgh Speed Serial Interface (HSSI)

Konfigurasi PPP protocol

Default protocol point-to-point untuk router Cisco adalah HDLC (High-Level Data Link Control) yang mana umum dipakai pada leased line seperti T1; T3 dll, akan tetapi HDLC tidak support authentication. KDLC adalah patennya Cisco jadi bukan standard industri, jadi hanya bisa dipakai sesama Cisco saja.

Berikut ini adalah implementasi PPP protocol :

Router# configure terminal
Router(config)# interface serial 0
Router(config-if) # encapsulation ppp
Router(config-if) # exit

PPP protocol diinisialisasi dan di enable pada interface serial 0. Langkah selanjutnya adalah men-set jenis authentication yang dipakai

Router(config) # int s0
Router(config-if) # ppp authentication pap
Or you can use the CHAP authentication method.
Router(config-if) # ppp authentication chap
Router # show int s0


CHAP direkomendasikan sebagai metoda authentication PPP protocol, yang memberikan suatu authentication terenkripsi dua arah yang mana lebih secure daripada PAP. Jika jalur sudah tersambung, kedua server di masing-masing ujung saling mengirim pesan ‘Challenge’. Segera setelah pesan ‘Challenge’ terkirim, sisi remote yang diujung akan merespon dengan fungsi ‘hash’ satu arah menggunakan Message Digest 5 (MD5) dengan memanfaatkan user dan password mesin local. Kedua sisi ujung router harus mempunyai konfigurasi yang sama dalam hal PPP protocol ini termasuk metoda authentication yang dipakai.


Router(config)# username router password cisco
Router(config)# interface serial 0
Router(config-if)# encapsulation ppp
Router(config-if)# ppp chap hostname router
Router(config-if)# ppp authentication chap


PPP protocol - CHAP authenticating :
  • Konfigurasi kedua router dengan username dan password
  • Username yang dipakai adalah hostname dari router remote
  • Password yang dikonfigurasikan harus sama
Penjelasan mengenai Pengertian PPP (Point to Point Protocol) sudah lengkap, tinggal Anda pahami dan semoga bermanfaat ilmu yang Santekno berikan. Terima kasih.

Read More